What are CP and EP Browser Requirements?

We design Customer Protect and Enterprise Protect to support the latest web browsers. We support the current versions of ChromeFirefoxSafariMicrosoft Edge and Internet Explorer 11.

Note: We support IE 9 and above. IE 8 and below is not supported. If you try and access our portal on a unsupported version, you will receive a message stating your version is unsupported. 

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk